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1 Getting Started

Spreadsheet Link Product Description
Use MATLAB from Microsoft Excel

1-2

Spreadsheet Link connects Excel® spreadsheet software with the MATLAB® workspace, enabling you
to access the MATLAB environment from an Excel spreadsheet. With Spreadsheet Link software, you
can exchange data between MATLAB and Excel, taking advantage of the familiar Excel interface
while accessing the computational speed and visualization capabilities of MATLAB.

Key Features

Data preprocessing, editing, and viewing in the familiar Excel environment
Sophisticated analysis of Excel data using MATLAB and application toolboxes

Delivery of Excel based applications, using MATLAB as a computational and graphics engine and
Excel as an interface

Interactive selection of available functions using the MATLAB Function Wizard
Visual interface for customization of all Spreadsheet Link preferences



Installation

Installation

In this section...

“Product Installation” on page 1-3
“Supported Excel Versions” on page 1-3
“Files and Folders Created by the Installation” on page 1-3

“After You Upgrade the Spreadsheet Link Software” on page 1-4

To use Spreadsheet Link, you must install Microsoft Excel first, and then install Spreadsheet Link.
Ensure that you use the correct MATLAB version based on the supported version of Excel. After
Spreadsheet Link is installed on your computer, you must set up the Spreadsheet Link add-in in
Excel.

Product Installation

Install the Microsoft Excel product before you install the MATLAB and Spreadsheet Link software. To
install the Spreadsheet Link add-in, follow the instructions in the MATLAB installation
documentation. Select the Spreadsheet Link check box when choosing components to install.

Note If you have several versions of MATLAB installed on your computer, Spreadsheet Link uses the
version that you registered last.

To install the Spreadsheet Link add-in, you need administrator system privileges on the computer.
Contact your system administrator to enable these privileges.

Supported Excel Versions

Use the following table to determine the correct MATLAB version to install, based on the version of
Excel installed on your computer. Each row in the table matches the MATLAB version with the
supported versions of Excel.

MATLAB Version Excel Versions

R2016b and later 2019, 2016, 2013, 2010, 2007
R2013b 2013, 2010, 2007

R2010b 2010, 2007

R2007a 2007

Files and Folders Created by the Installation

Note The MATLAB root folder, matlabroot, is where MATLAB is installed on your system.

The Spreadsheet Link installation program creates a subfolder under matlabroot\toolbox\. The
exlink folder contains these files:

1-3
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* excllink.xlam: The Spreadsheet Link add-in for Microsoft Excel
* Ex1liSamp.x1ls: Spreadsheet Link example files described in this documentation

After You Upgrade the Spreadsheet Link Software

If MATLAB and Spreadsheet Link are installed on your computer, to upgrade to a newer version:

Install the new version of MATLAB and Spreadsheet Link.
Start MATLAB and a Microsoft Excel session.
Configure the Spreadsheet Link software. For details, see “Add-In Setup” on page 1-5.

A W N R

If you have existing workbooks with macros that use Spreadsheet Link, update references to
Spreadsheet Link in each workbook.

To update the references in an existing workbook in Microsoft Excel:

1 In a Microsoft Excel session, open the Visual Basic® Editor window by clicking Visual Basic on
the Developer tab. (If you do not find the Developer tab, see the Excel Help.)

2 In the left pane, select a module for which you want to update a reference.

3  From the main menu, select Tools > References.

4 In the References dialog box, select the SpreadsheetLink2007_2010 check box.
5 Click OK.

See Also

More About

. “Add-In Setup” on page 1-5



Add-In Setup

Add-In Setup

In this section...

“Configure Microsoft Excel” on page 1-5
“Work with Excel Macros” on page 1-9

“Work with Microsoft Visual Basic Editor” on page 1-9

Configure Microsoft Excel
To enable the Spreadsheet Link add-in, start a Microsoft Excel session and follow these steps.

If you use Microsoft Excel 2007:

1 .
[

Click =" the Microsoft Office button.
2 Click Excel Options. The Excel Options dialog box opens.

If you use Microsoft Excel 2010 and later versions:

1 Select File from the main menu.
2 Click Options. The Excel Options dialog box opens.

The next steps are the same for both versions:

Click Add-Ins.

From the Manage selection list, choose Excel Add-Ins.
Click Go. The Add-Ins dialog box opens.

Click Browse.

gua A W N R

Select matlabroot\toolbox\exlink\excllink.xlam. (matlabroot returns the full path to
the folder where MATLAB is installed.)

6 Click Open. In the Add-Ins dialog box, the Spreadsheet Link for use with MATLAB and Excel
check box is selected.

1-5



1 Getting Started

Add-Ins

Add-Ins available:

("] Analysis ToolPak > oK
[] Analysis ToolPak - VBA
[ Euro Currency Taols Cancel
["] solver add-in

Spreadsheet Link 3.2.5 for use with MATLAE and Excel

Browse...

Automation...

I §

Spreadsheet Link 3.2.5 for use with MATLAE and Excel
Spreadsheet Link 3.2.5 for use with MATLAE and Excel

7  Click OK to close the Add-Ins dialog box.
8 Click OK to close the Excel Options dialog box.

The Spreadsheet Link add-in loads now and with each subsequent Excel session.

The MATLAB Command Window button appears on the Microsoft Windows® taskbar.

The MATLAB group appears on the top right of the Home tab in your Excel worksheet.

1-6



Add-In Setup

i A

wort & Find &
ilter = Select -

19 | Start MATLAE

-

Send data to MATLAE

Send named ranges to MATLAR
et data from MATLAE

Run MATLAE command

et MATLAE figure

MATLAE Function YWizard

Preferences

Spreadsheet Link is ready for use.

Right-click a cell to list the MATLAB options.
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Calibri = 11 + A" A" % * % 0 E
B = & A -
& Cut
53 Copy

{3, Paste Options:
=

Paste Special...
Insert...

Delete...

Clear Contents
Filter
Sort

|

-
Insert Comment

@ Format Cells..,

Pick From Drop-down List...
Define Mame...

’__Q_,_J Hyperlink...

MATLAB

5end data to MATLAB
Send named ranges to MATLABE
et data from MATLAB
Run MATLAE command
Get MATLAE figure

Function Wizard

Note If the options are missing from the context menu and if the Trust Center dialog box has the
Require Application Add-ins to be signed by Trusted Publisher check box selected, then you
must click the Enable Content button for every session.

To check the settings in the Trust Center dialog box:

Click the Developer tab.

Click Add-ins.

In the Code group, click the Macro Security button. The Trust Center dialog box opens.




Add-In Setup

Work with Excel Macros
To work with Excel macros, follow these steps to enable the Developer tab on the Excel ribbon.

If you use Microsoft Excel 2007:

i o) . i
Click =" the Microsoft Office button.
2 Click Excel Options. The Excel Options dialog box opens.

If you use Microsoft Excel 2010 and later versions:

1 Click the File menu.
2 Click Options. The Excel Options dialog box opens.

The next steps are the same for both versions:

Click Customize Ribbon.

2 From the Main Tabs list, select Developer and click OK. The Excel ribbon displays the
Developer tab.

3 In the Code section of the Developer tab, click Macros. The Macro dialog box opens. Use this
dialog box to run existing macros, create macros, and edit and delete macros.

Work with Microsoft Visual Basic Editor

To enable Spreadsheet Link as a Reference in the Microsoft Visual Basic Editor:

1 Open a Visual Basic session. Click the Visual Basic button on the Developer tab, or press Alt
+F11.

Note For instructions about displaying the Developer tab, see Excel Help.

In the Visual Basic toolbar, select Tools > References.

In the References — VBA Project dialog box, select the SpreadsheetLink or
SpreadsheetLink2007_2010 check box.

4 Click OK.

See Also
matlabroot

More About

. “Installation” on page 1-3
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Set Spreadsheet Link Preferences

1-10

In this section...

“Preferences Dialog Box” on page 1-10

“Preferences in Worksheet Cells” on page 1-10

To control how Spreadsheet Link and MATLAB behave when Spreadsheet Link starts MATLAB in

Microsoft Excel, you can set preferences with the Preferences dialog box or within individual
worksheet cells.

Preferences Dialog Box

1 Click Preferences in the MATLAB group. The MATLAB group appears to the top right of the
Home tab in your Excel worksheet.

o =

Preferences @

wwew. riathwarks.co

[ Start MATLAE at Excel startup i

MATLAE program id

| 9.0

MATLAE startup folder

B

[ Use MATLAE desktop

[ Show MATLAE errors

r Force use of MATLAB cell arrays with
MLPutMatrix

[ Treat missing/empty cells as MaM

Ok Cancel

2 Set your preferences by selecting check boxes and filling in the text boxes. For the MATLAB
program id, enter the MATLAB version as shown in the Windows registry. For the MATLAB
startup folder, enter the full path of the startup folder. Select Use MATLAB desktop to start
MATLAB in full desktop mode (only the Command Window opens by default).

Preferences in Worksheet Cells

To set a preference in a worksheet cell in Microsoft Excel, enter text that runs the corresponding
Spreadsheet Link function in the worksheet cell. For example, to set the MATLAB version in a
worksheet cell:



Set Spreadsheet Link Preferences

1  Set the MATLAB version to 9.0, which corresponds to MATLAB R2016a, by entering this text.

=MLProgramId("9.0")

A B
1 |:MLPngramld|{”5.D“}|

2 To run the function, press enter.
For details, see MLProgramId.

See Also
MLPutMatrix

More About

. “Worksheet Cell Errors” on page 3-2
. “Startup Errors” on page 3-11
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Start and Stop Spreadsheet Link and MATLAB

1-12

In this section...

“Start Spreadsheet Link and MATLAB Automatically” on page 1-12
“Start Spreadsheet Link and MATLAB Manually” on page 1-12
“Connect to an Already Running MATLAB Session” on page 1-12
“Specify the MATLAB Startup Folder” on page 1-13

“Stop Spreadsheet Link and MATLAB” on page 1-13

Start Spreadsheet Link and MATLAB Automatically

When installed and configured according to the instructions in “Add-In Setup” on page 1-5, the
Spreadsheet Link and MATLAB software automatically start when you start a Microsoft Excel session.

Start Spreadsheet Link and MATLAB Manually

1 Select Tools > Macro.

* 1In Excel 2007, click the View or Developer tab, and then click the Macros button.

* In Excel 2010, click the View menu and select Macros on the Excel toolstrip, and then click
View Macros.

Enter matlabinit into the Macro Name/Reference field.
3 (Click Run. The MATLAB Command Window button appears on the Microsoft Windows taskbar.

Connect to an Already Running MATLAB Session

By default, Spreadsheet Link starts a new MATLAB session. Alternatively, it can connect to an already
running MATLAB session.

Note If several versions of MATLAB are installed on your computer, Spreadsheet Link always uses
the last registered version. If you try to connect to an already running MATLAB session that is not the
last registered version, Spreadsheet Link starts a new MATLAB session. Spreadsheet Link does not
connect to the existing one. To change the last registered version, see “Startup Errors” on page 3-

11.

To connect a new Excel session to an already running MATLAB session:
1 [n MATLAB, enter the following command:
enableservice('AutomationServer',true)

This command converts a running MATLAB session into an Automation server.
2  Start a new Excel session. It automatically connects to the running MATLAB session.

Alternatively, you can start MATLAB as an automation server from the beginning. To start MATLAB as
an automation server, use the automation command-line option:




Start and Stop Spreadsheet Link and MATLAB

matlab -automation

This command does not start MATLAB in a full desktop mode. To do so, use the -desktop option:

matlab -automation -desktop

If you always use MATLAB as an automation server, modify the shortcut that you use to start
MATLAB:

1 Right-click your MATLAB shortcut icon. (You can use the icon on your desktop or in the Windows
Start menu.)
Select Properties.
Click the Shortcut tab.

Add -automation in the Target field. Remember to leave a space between matlab.exe and -
automation.

5 Click OK.

For details, see “Manually Create Automation Server”.

Specify the MATLAB Startup Folder

MATLAB starts in the MATLAB root folder and completes the initialization. After starting, MATLAB
changes to the Spreadsheet Link MATLAB startup folder. For details about specifying the startup
folder, see MLStartDir.

Stop Spreadsheet Link and MATLAB

If you started the Spreadsheet Link and MATLAB software from the Excel interface:
* To stop both the Spreadsheet Link and MATLAB software, close the Excel session as you normally
would.

» To stop the Spreadsheet Link and MATLAB software and leave the Excel session running, enter
the =MLClose () command into an Excel worksheet cell. You can use the MLOpen or matlabinit
function to restart the Spreadsheet Link and MATLAB sessions manually.

If you connected an Excel session to an existing MATLAB session, close Excel and MATLAB sessions
separately. Closing one session does not automatically close the other.

1-13
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Create Diagonal Matrix Using Microsoft Excel Ribbon

1-14

This example shows how to execute Spreadsheet Link functions to export a named range in a
worksheet to MATLAB and create a diagonal matrix using the Microsoft Excel ribbon.

The MATLAB group on the Microsoft Excel ribbon contains commands for common Spreadsheet Link
functions. For the list of common functions, see “Execute Spreadsheet Link Functions” on page 1-31.

This example assumes that MATLAB is running after Microsoft Excel opens. For starting MATLAB,
see “Start and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from Al through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

testData - Je 1

A B C D E
1 1 2 3 1 5

On the Home tab of the Microsoft Excel ribbon, click the MATLAB group in the top-right corner.
Then, select Send named ranges to MATLAB. When you select this command, the software
executes MLPutRanges.

o7 & 4\
ort & Find &
ilter = Select -
19 |\ Start MATLAE

Send data to MATLAER

-

Send named ranges to MATLAE
Get data from MATLAE

Fun MATLAE cammand

Get MATLAE figure

MATLAE Function YWizard
Preferences

Microsoft Excel exports the named range testData into the MATLAB variable testData in the
MATLAB workspace.



Create Diagonal Matrix Using Microsoft Excel Ribbon

Cormrmand Window ™ Mdorkspace @
'? Mew to MATLABT Wifatch this Video, see Examples, orre | Mame Walue Min hla
> teatData ] testData [1,2,3,4,5] 1 5
testData =
1 2 3 4 5
fx s>

Select the MATLAB group option Run MATLAB Command. When you select this command,
Microsoft Excel displays a dialog box. Next, create a diagonal matrix. Use the diag function to
specify testData as the input argument and d as the output argument. Enter this MATLAB
command in the dialog box and click OK.

d = diag(testData)

The software executes the MLEvalString function. The MATLAB variable d appears in the MATLAB
workspace and contains a diagonal matrix.

Retrieve the diagonal matrix into the worksheet by selecting cell A3. Select the MATLAB group option
Get data from MATLAB. When you select this command, Microsoft Excel displays a dialog box.
Retrieve the diagonal matrix in d by entering d in the dialog box and clicking OK. The software
executes the MLGetMatrix function.

The diagonal matrix displays in cells A3 through E7.

A E C D E

1 1 2 3 4 5
2

3 | 1.| 0 0 0 0
4 0 2 0 0 0
> 0 0 3 0 0
5] 0 0 0 4 0
7 0 0 0 0 5

See Also
MLPutRanges | MLEvalString | MLGetMatrix

More About

. “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
. “Create Diagonal Matrix Using Worksheet Cells” on page 1-19

. “Create Diagonal Matrix Using VBA Macro” on page 1-21

. “Execute Spreadsheet Link Functions” on page 1-31

1-15
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Create Diagonal Matrix Using Microsoft Excel Context Menu

1-16

This example shows how to execute Spreadsheet Link functions to export a named range in a
worksheet to MATLAB and create a diagonal matrix using the Microsoft Excel context menu.

The MATLAB group menu in the Microsoft Excel context menu contains commands for common
Spreadsheet Link functions. For the list of common functions, see “Execute Spreadsheet Link
Functions” on page 1-31.

This example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from Al through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

testData - Je 1

A B C D E
1 1 2 3 1 5

To find the command that exports the named range to MATLAB, right-click another cell outside of the
named range in the worksheet. The Microsoft Excel context menu appears. To see the MATLAB group
menu, select MATLAB.



Create Diagonal Matrix Using Microsoft Excel Context Menu

Calibri 11 = A" A" % + % » |[ag

+.0 .00
00 .0

& Cut
=3 Copy
{3, Paste Options:

=

Paste Special...

Insert...
Delete...

Clear Contents

Filter 4
Sort 4

Insert Comment

Format Cells...

C N

Pick From Drop-down List...

Define Mame...

®

Hyperlink...

MATLAE 4 Send data to MATLAB
Send named ranges to MATLABE
et data from MATLAB 4
Run MATLAE command
Get MATLAE figure
Function Wizard

Select Send named ranges to MATLAB. When you select this command, the software executes
MLPutRanges.

Microsoft Excel exports the named range testData into the MATLAB variable testData in the
MATLAB workspace.
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Cormrmand Window ™ Mdorkspace @
'? Mew to MATLABT Wifatch this Video, see Examples, orre | Mame Walue Min hla
> testData ] testData [1,2,3,4,5] 1 5
testData =
1 2 3 4 5
fx s>

Select the MATLAB group option Run MATLAB Command. When you select this command,
Microsoft Excel displays a dialog box. Next, create a diagonal matrix. Use the diag function to
specify testData as the input argument and d as the output argument. Enter this MATLAB
command in the dialog box and click OK.

d = diag(testData)

The software executes the MLEvalString function. The MATLAB variable d appears in the MATLAB
workspace and contains a diagonal matrix.

Retrieve the diagonal matrix into the worksheet. First select cell A3, and then select the MATLAB
group option Get data from MATLAB > d. The software executes the MLGetMatrix function.

The diagonal matrix displays in cells A3 through E7.

A E C D E

1 1 2 3 4 5
2

3 | 1.| 0 0 0 0
4 0 2 0 0 0
> 0 0 3 0 0
5] 0 0 0 4 0
7 0 0 0 0 5

See Also
MLPutRanges | MLEvalString | MLGetMat rix

More About

. “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
. “Create Diagonal Matrix Using Worksheet Cells” on page 1-19

. “Create Diagonal Matrix Using VBA Macro” on page 1-21

. “Execute Spreadsheet Link Functions” on page 1-31



Create Diagonal Matrix Using Worksheet Cells

Create Diagonal Matrix Using Worksheet Cells

This example shows how to execute Spreadsheet Link functions to export a named range in the
worksheet to MATLAB and create a diagonal matrix using Microsoft Excel worksheet cells.

The example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from Al through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

testData - Je 1

A B C D E
1 1 2 3 a 5

Enter the Spreadsheet Link function MLPutRanges directly into the worksheet cell as a worksheet
formula. Double-click cell A3. Enter this text.

=MLPutRanges ()

Press Enter. Microsoft Excel exports the named range testData into the MATLAB variable
testData in the MATLAB workspace. After a Spreadsheet Link function successfully executes as a
worksheet formula, the cell contains the value 0. While the function executes, the cell shows the
entered formula.

Cararmand Window ™ Mdorkspace @
'? Mew to MATLABT Wifatch this Video, see Examples, orre | Mame Walue Min Ml a
»» testData 1 testData [1,2,3,4,5] 1 5
testData =
1 z 3 4 5
Jx =

Double-click cell A5. Next, create a diagonal matrix. Use the diag function to specify testData as
the input argument and d as the output argument. The Spreadsheet Link function MLEvalString
executes the MATLAB command. Enter this text.

=MLEvalString("d = diag(testData);")

Press Enter. MATLAB executes the diag function. The MATLAB variable d appears in the MATLAB
workspace and contains the diagonal matrix.

Double-click cell A7. Now retrieve the diagonal matrix into the worksheet using the Spreadsheet Link
function MLGetMat rix. Enter this text.
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=MLGetMatrix("d","A9")

The diagonal matrix displays in cell A9 through E13.

A B C D E
1 1 2 3 4 5
2
3 0
4
2 0
&
7 0
8 :I
2! 1 0 0 0 i
10 0 2 0 0 0
11 0 0 3 0 0
12 0 0 0 4 0
13 0 0 0 0 5

See Also
MLPutRanges | MLPutMatrix | MLEvalString | MLGetMatrix

More About

. “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14

. “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
. “Create Diagonal Matrix Using VBA Macro” on page 1-21

. “Execute Spreadsheet Link Functions” on page 1-31
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Create Diagonal Matrix Using VBA Macro

This example shows how to execute Spreadsheet Link functions to export a named range in the
worksheet to MATLAB and create a diagonal matrix using a Microsoft Excel VBA macro.

The example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

In a worksheet, enter the numbers 1 through 5 into the range of cells from Al through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

testData - Je 1

A B C D E
1 1 2 3 4 5

On the Developer tab in Microsoft Excel, click Visual Basic. The Visual Basic Editor window opens.

Insert a new module and create a diagonal matrix from the data in testData. To insert the module,
select Insert > Module. In the Code section, enter this VBA code that contains a macro named
Diagonal.

Sub Diagonal()
MLPutRanges
MLEvalString "b = diag(testData);"
MLGetMatrix "b", "A3"
MatlabRequest

End Sub

The Diagonal macro exports the named range into the MATLAB variable testData using the
MLPutRanges function. Then, the macro uses the MLEvalString function to execute MATLAB code.
The MATLAB code creates a diagonal matrix from the data in testData using the diag function. The
code assigns the diagonal matrix to the MATLAB variable b. Then, the macro uses the MLGetMatrix
function to import the diagonal matrix into the worksheet.

Copy and paste the code into the Visual Basic Editor from the HTML version of the documentation.

For details about working with modules, see Excel Help.

Run the macro by clicking Run Sub/UserForm (F5). For details about running macros, see Excel
Help.

The diagonal matrix displays in the worksheet cells A3 through E7.
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A E C D E

1 1 2 3 4 5
2

3 | 1.| 0 0 0 0
4 0 2 0 0 0
> 0 0 3 0 0
5] 0 0 0 4 0
7 0 0 0 0 5

See Also
MLPutRanges | MLEvalString | diag

More About

. “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14

. “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
. “Create Diagonal Matrix Using Worksheet Cells” on page 1-19

. “Execute Spreadsheet Link Functions” on page 1-31
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Find and Execute MATLAB Function Using MATLAB Function
Wizard

This example shows how to find and execute the triu function using the MATLAB Function Wizard
for Spreadsheet Link. You can use the Function Wizard to find any MATLAB function.

First, open the MATLAB Function Wizard from Microsoft Excel. From the Home tab, select the
MATLAB group option MATLAB Function Wizard. Locate the triu MATLAB function, choose the
function signature, and then execute it.

-

MATLAR Function Wizard ==

- M)

1. Select a category:

I matablelmat - Elementary matrices and matrix rnanipj Update |

2. Select a function;

ril i
frue —
vander ;I

3. Select a function signature;
TRIU(K)

TRIU(K, K

friu

Function Help:

TRIL Extract upper triangular part. i
TRIU(X) is the upper triangular part of X,
TRIU(X K] is the elements on and above the K-th diagonal of
¥, K =0is the main diagonal, K = 0is above the main
diagonal and K < 0 is below the main diagonal.

See also TRIL, DIAG,

L

Ok

Alternatively, you can execute the function in a Microsoft Excel worksheet cell by using function
matlabfcn or matlabsub.

List Folders and Function Categories

All folders or categories in the current search path appear in the Select a category field of the
MATLAB Function Wizard. Click an entry to select it. Each entry in the list appears as a folder path
and a description read from the Contents.m file in that folder. If no Contents.m file is found, the
category list displays contains this message:

finance\ finsupport -(No table of contents file)
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1-24

Refresh and Select Category
Click Update to refresh the category list. For details about the search path, see path.

The Select a function field displays a list of available functions for that category. Click the function
name you want to execute. For help with the selected function, view the Function Help field.

Select Function Signature and Enter Formula

The Select a function signature field displays available signatures for that function. Click a
function signature to select it. The Function Arguments dialog box appears.

-

Function Argurmnents @

TRIU Inputs: - |

Optional output cell(s): | J
TRIL Extract upper triangular part. “
TRIU(X) is the upper triangular part of X,

TRIU(X K] is the elements on and above the K-th diagonal of
¥, K =0is the main diagonal, K = 0is above the main
diagonal and K < 0 is below the main diagonal. ﬂ

Ok | ‘Cancel :

Specify the worksheet cell that contains the input argument X. By default, the output of the selected
function appears in the current worksheet cell using the function matlabfcn.

See Also
matlabfcn | matlabsub

More About
. “Find Custom MATLAB Function Using MATLAB Function Wizard” on page 1-25
. “Execute Spreadsheet Link Functions” on page 1-31
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Find Custom MATLAB Function Using MATLAB Function Wizard

This example shows how to write a custom function and find it using the MATLAB Function Wizard
for Spreadsheet Link. To execute MATLAB functions using the MATLAB Function Wizard, see “Find
and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23.

Create and save a custom function in MATLAB. First, create a help header in the function that
contains supported function signatures to use with the MATLAB Function Wizard. Write the function
that calculates the Fibonacci numbers, and then save the function in the folder Documents\MATLAB.

function f = fibonacci(n)
FIBONACCI(N) Calculate the Nth Fibonacci number.
N must be a positive integer.

%
%

ifn<®©
error('Invalid number."')
elseif n == 0
f=0;
elseif n ==
f=1;
else
f = fibonacci(n - 1) + fibonacci(n - 2);
end;

end
For writing MATLAB functions, see “Create Functions in Files”.

Add the folder where you saved the function to the MATLAB search path. You can use the pathtool
function or select Set Path in the MATLAB Toolstrip.

Open the MATLAB Function Wizard in Microsoft Excel using either the Microsoft Excel ribbon or
context menu. Select the folder where you saved your function.
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MATLAR Function Wizard ==

- M)

1. Select a category:

I Documents MATLAB - (Mo table of contents file) j Update |

2. Select a function:
fibonacd

3. Select a function signature:

FIBONACCI(N)
fibonacc

Function Help:

FIBOMACCI(MN) Compute the Mth Fibonacd number.,
M must be a positive integer.

Ok |

To execute this function, follow the steps in “Find and Execute MATLAB Function Using MATLAB
Function Wizard” on page 1-23.

See Also
matlabfcn | matlabsub

More About
. “Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
. “Execute Spreadsheet Link Functions” on page 1-31
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Return Multiple Output Arguments from MATLAB Function

This example shows how to execute a MATLAB function that returns multiple output arguments in
Microsoft Excel using a Microsoft Excel VBA macro. The macro writes multiple output arguments
from the MATLAB workspace to Microsoft Excel cells.

To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

This example calculates the singular value decomposition of a matrix using svd.

In the Microsoft Excel cells from Al through C3, create a range of data. Enter numbers from 1
through 3 in cells Al through A3. Enter numbers from 4 through 6 in cells B1 through B3. Enter
numbers from 7 through 9 in cells C1 through C3.

X - e 1
A B C D
1 1 2 3
2 4 3
3 7 ) 9
[
4

Create a Microsoft Excel VBA macro named applysvd. For details about creating macros, see Excel

Help.

Public Sub applysvd()
MLOpen
MLPutMatrix "x", Range("Al:C3")
MLEvalString ("[u,s,v] = svd(x);")
MLGetMatrix "u", "A5"
MLGetMatrix "s", "A9"
MLGetMatrix "v", "Al3"
MatlabRequest
MLClose

End Sub

The macro:

1 Starts MATLAB.

2 Sends the data in the Al through C3 cell range to the MATLAB workspace and assigns it to the
MATLAB variable x.

3 Runs svd with the input argument x and output arguments u, s, and v.

Individually retrieves data for one output argument into a specific Microsoft Excel cell while
accounting for the size of each output data matrix to avoid overwriting data. For the first output
argument, the macro retrieves the data for the output argument u into cell A5.

5 Closes MATLAB.

Run applysvd. MATLAB runs svd and populates the specified cells with data from the three output
arguments.
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AS - I
A B 2

1 1 3
2 4

3 7 9
4

5 | -0. 21481 0.8872 0.4082
3] -0.5206 0.2496 -0.8165
7 -0.8263 -0.3879 0.4082
8

9 16.8481 0.0000 0.0000
10 0.0000 1.0684 0.0000
11 0.0000 0.0000 0.0000
12

13 -0.4797  -0.7767 0.4082
14 -0.5724  -0.0757  -0.8165
15 -0.6651 0.6253 0.4082

16

For details about running macros, see Excel Help.

See Also
svd | MLOpen | MLGetMatrix | MLPutMatrix | MLEvalString | MLClose

More About
. “Create Diagonal Matrix Using VBA Macro” on page 1-21
. “Execute Spreadsheet Link Functions” on page 1-31
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Convert Dates Between Microsoft Excel and MATLAB

Default Microsoft Excel date numbers represent the number of days that have passed since January
1, 1900. For example, January 1, 1950 is represented as 18264 in the Excel software.

However, MATLAB date numbers represent the number of days that have passed since January 1,
0000, so January 1, 1950 is represented as 712224 in the MATLAB software. Therefore, the difference
in dates between the Excel software and the MATLAB software is a constant, 693960 (712224 minus
18264).

To use date numbers in MATLAB calculations, apply the 693960 constant as follows:

e Add it to Excel date numbers that are read into the MATLAB software.
* Subtract it from MATLAB date numbers that are read into the Excel software.

Note If you use the optional Excel 1904 date system, the constant is 695422.

Dates are stored internally in the Excel software as numbers and are unaffected by locale.

See Also

Related Examples

. “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
. “Create Diagonal Matrix Using VBA Macro” on page 1-21
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Localization Information

1-30

This document uses Microsoft Excel with an English (United States) Microsoft Windows
regional setting for illustrative purposes. If you use Spreadsheet Link with a non-English (United
States) Windows desktop environment, certain syntactical elements might not work as illustrated.
For example, you might have to replace the comma delimiter within Spreadsheet Link commands
with a semicolon or other operator.

Please consult your Windows documentation to determine which regional setting differences exist
among non-US versions.

See Also

Related Examples

. “Set Spreadsheet Link Preferences” on page 1-10
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Execute Spreadsheet Link Functions

Spreadsheet Link functions manage the connection and data exchange between Microsoft Excel and
MATLAB, without leaving the Microsoft Excel environment.

To execute Spreadsheet Link functions, you must:

» Understand the differences between these functions and Microsoft Excel functions.
* Choose the right function type, execution method, and calculation mode for your situation.
* Decide how to specify functions and arguments.

Spreadsheet Link and Microsoft Excel Function Differences

In Microsoft Excel, entering Spreadsheet Link functions can be similar to Microsoft Excel functions.
The differences include:

* Spreadsheet Link functions perform an action, while Microsoft Excel functions return a value.

» Spreadsheet Link function names are case-insensitive. Entering either MLPutMatrix or
mlputmatrix executes the MLPutMatrix function.

* MATLAB function names and variable names are case-sensitive. For example, BONDS, Bonds, and
bonds are three different MATLAB variables.

Spreadsheet Link Function Types
There are link management and data management functions in Spreadsheet Link.

Link management functions initialize, start, and stop the Spreadsheet Link and MATLAB software.
Execute the matlabinit function from the Excel Tools > Macro menu or in macro subroutines.

Data management functions copy data between Microsoft Excel and the MATLAB workspace. These
functions execute MATLAB commands in Microsoft Excel. Except for MLPutVar and MLGetVar, you
can execute any data management function as a worksheet cell formula or in a VBA macro. The
MLPutVar and MLGetVar functions execute only in VBA macros.

Spreadsheet Link Function Execution Method

You can execute Spreadsheet Link functions using these various methods.
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Execution Method

Advantages

Limitations

Microsoft Excel ribbon

Quickly access common
Spreadsheet Link functionality
in the MATLAB group:

* matlabinit

* MLPutMatrix
* MLPutRanges
* MLGetMatrix
* MLEvalString
* MLGetFigure

¢ MATLAB Function Wizard
(For details, see “Find and
Execute MATLAB Function
Using MATLAB Function
Wizard” on page 1-23.)

* Preferences (For details, see
“Set Spreadsheet Link
Preferences” on page 1-10.)

Full Spreadsheet Link
functionality is unavailable.

Microsoft Excel context menu

Quickly access common
Spreadsheet Link functionality
in a worksheet cell:

* MLPutMatrix
* MLPutRanges
* MLEvalString

* MLGetFigure

* MATLAB Function Wizard
(For details, see “Find and
Execute MATLAB Function
Using MATLAB Function
Wizard” on page 1-23.)

e MLGetMatrix

Full Spreadsheet Link
functionality is unavailable.

Microsoft Excel worksheet cell

Execute any Spreadsheet
Link function.

¢ Execute MATLAB functions.

You cannot execute MLGetVar,
MLPutVar, or